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BAB 1 

KONEKSI KE MICROSOFT ACCESS 

1.1 Komponen ADO 

Program Ms Access sebagai aplikasi pembangun basis data bisa dikoneksikan 

dan dikontrol menggunakan Delphi. Dengan dikontrol Delphi aplikasi basis data bisa 

dibuat dengan tampilan lebih baik dan dikendalikan validasinya sehingga meminimalisir 

kemungkinan terjadinya kesalahan (error). 

Agar Delphi dan Access bisa terhubung, bisa digunakan komponen 

ADOConnection dari tab ADO, sedangkan untuk mengakses tabelnya ada banyak 

teknik, bagi yang sudah terbiasa menggunakan Query bisa memakai ADOQuery, bagi 

yang belum terbiasa bisa juga menggunakan ADOTable atau ADODataset. 

 

 

 

 

Untuk komponen juga ada bermacam-macam teknik, bisa menggunakan 

komponen yang sudah diajarkan, atau bisa juga menggunakan komponen yang 

terhubung langsung dengan basis data, komponen ini terletak pada tab Data Control. 

Tiap ADOTable/ADODataset/ADOQuery dihubungkan dengan 

ADOConnection, sedangkan untuk komponen sebelum dihubungkan dengan 

ADOTable/ADODataset/ADOQuery harus melalui komponen DataSource yang berada 

di tab Data Access. 

 

ADOConnection 

ADODataset 

ADOQuery 

ADOTable 
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1.2 Pengaturan Pada Microsoft Access 

1. Buat folder Perpus. 

2. Jalankan Program Microsoft Access 

3. Buat Database Baru 

 

4. Pilih folder tempat meletakkan file tersebut, dalam hal ini letakkan di folder Perpus 

yang sudah dibuat tadi. 
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5. Isi nama file database, misalnya DBPerpus kemudian ganti tipe filenya menjadi 

Microsoft Office Access Databases (2002-2003) format (*.mdb), karena Delphi 

hanya membaca format *.mdb, kemudian create 

 

6. Klik tombol Design View (untuk membuat table berikutnya bisa klik tab Create lalu 

pilih Table)  

 

 

7. Isi nama tabelnya tPenerbit 
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8. Isi fieldnya seperti berikut 

 

 Field Name jangan menggunakan spasi,  

 Field Size isi dibawah,  

 Description boleh ditulis boleh tidak. 

 IDPenerbit memiliki Data Type AutoNumber agar dibuat kode otomatis oleh 

MS Access 

 Penerbit memiliki Data Type Text yang akan diisi melalui Delphi 

9. Save lalu tutup Microsoft Access supaya tidak terjadi error ketika proses koneksi 

pertama kali 

1.3 Data Modul 

1. Buka Delphi 

2. Untuk memulai mebuat program maka kita harus terlebih dahulu membuat 

projectnya. 

   File –> new –> application  

3. Kemudian File –> Save All.. simpan unit1.pas menjadi uPenerbitTampil.pas, unit 

ini nantinya akan dipakai untuk form master penerbit, untuk menyimpan project 

simpan dengan nama Perpus.dpr dan pastikan satu folder dengan database berada. 

4. Menu File -> New -> Data Module -> ganti name menjadi DM 

5. Save dengan nama unit uDM.pas 

6. Pasang Komponen ADOConnection dari tab ADO ke Data Module 
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7. Klik 2x (Double Click) ADOConnection maka akan tampil 

 

8. Klik Build maka akan tampil 

        

Pilih Microsoft Jet 4.0 OLE DB Provider -> Next, Tekan tombol  , Kemudian 

pilih file dbPerpus.mdb yang sudah dibuat tadi, Bisa dicoba Test Connection dulu 

untuk memastikan bahwa database sudah terkoneksi, jika masih error pastikan Project 

Delphi berada dalam satu folder dengan file DBPerpus.mdb. Kemudian hapus alamat 

folder sehingga menjadi seperti gambar berikut 
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9. Tekan OK 

10. Atur Properties pada ADOConnection 

Komponen Properties  Value Keterangan 

ADOConection Name CON Mengubah nama menjadi ‘CON’ 

 Login Prompt False Agar tidak ditanyakan User dan 

Pass 

 Connected true Status ‘Terkoneksi’ 

 

11. Tambahkan ADOQuery (Tab ADO) dan Data Source (Tab Data Access) 

12. Atur properties dan values-nya 

Komponen Properties  Value Keterangan 

ADOQuery1 Connection CON Menghubungkan dengan 

ADOConnection (CON) 

 Name aPenerbit Mengganti nama 

 SQL Select * from 

tPenerbit 

Pilih Table yang akan diakses 

 Active True Mengaktifkan table yang diakses 

DataSource1 Name dPenerbit Mengganti nama 

 DataSet aPenerbit Menghubungkan dengan 

ADOQuery 
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13. Save All 

1.4 Form Data Tampil 

1. Kembali ke Form1, File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk 

menghubungkan dengan Data Module yang sudah dibuat tadi  

2. Tambahkan, 1 DBGrid (Tab Data Controls), 6 Button (Tab Standard), 1 Label (Tab 

Standard), 1 Edit (Tab Standard) 
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3. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FPenerbitTampil Mengubah nama menjadi 

‘FPenerbitTampil’ 

 Caption Data Penerbit Tampil tulisan ‘Data Penerbit’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bTambah Mengganti nama button 

 Caption &Tambah Tulisan menjadi Tambah, 

shortcut alt+T 

Button2 Name bUbah Mengganti nama button 

 Caption &Ubah Tulisan menjadi Ubah, shortcut 

alt+U 

Button3 Name bHapus Mengganti nama button 

 Caption &Hapus Tulisan menjadi Hapus, shortcut 

alt+H 

Button4 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Button5 Name bTutup Mengganti nama button 

 Caption Tutu&p Tulisan menjadi Tambah, 

shortcut alt+P, T dan U sudah 

dipakai 

Button6 Name bCari Mengganti nama button 

 Caption &Cari Tulisan menjadi Cari,  shortcut  

alt+C 

Label1 Caption Cari Penerbit Mengganti tulisan 

Edit1 Name eCari Mengganti Nama 

 Text ‘’ Kosongkan tulisan 

DBGrid1 DataSource DM.dPenerbit Memilih Data Source 

 Option-dgEditing False Agar Grid tidak bisa diketik 
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4. Jika Semua pengaturan sudah selesai maka form menjadi seperti berikut 

 

5. Double klik tombol Batal untuk mengisi codingnya dengan isi sebagai berikut 

 

 

6. Double klik tombol Hapus untuk mengisi codingnya dengan isi sebagai berikut 
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7. Double klik tombol Cari untuk mengisi codingnya dengan isi sebagai berikut 

 

8. Jangan lupa untuk TOMBOL YANG PALING SUSAH yaitu tombol tutup  

 

9. Klik Form 1 Kali, Cari pada Events – On Show 

  

10. Double klik isi dengan kode berikut 

 

 

 

 

 

 

 

 

 

 

11. Untuk tombol Tambah dan Ubah akan diisi setelah selesai dibuat form Tambah Data 
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1.5 Form Data Tambah 

1. Buat Form Baru, Save dengan nama unit uPenerbitTambah.pas 

2. Tambahkan 1 Label, 1 Edit, dan 2 Button 

 

3. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FPenerbitTambah Mengubah nama menjadi 

‘FPenerbitTambah’ 

 Caption Tambah Penerbit Tampil tulisan ‘Tambah 

Penerbit’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bSimpan Mengganti nama button 

 Caption &Simpan Tulisan menjadi Simpan, 

shortcut alt+S 

Button2 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Label1 Caption Nama Penerbit Mengganti tulisan 

Edit1 Biarkan Biarkan Biarkan 
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4. File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk menghubungkan dengan Data 

Module 

5. File -> Use Unit (Alt+F11) -> Pilih uPenerbitTampil. 

6. Double klik tombol Simpan untuk mengisi codingnya dengan isi sebagai berikut 

 

7. Lagi lagi TOMBOL YANG PALING SUSAH yaitu tombol Batal  

 

8. Untuk pindah antar form bisa mengunakan Shift+F12 atau tombol berikut 
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9. Kembali ke fPenerbitTampil untuk mengisi tombol Tambah dan Ubah 

10. File -> Use Unit (Alt+F11) -> Pilih uPenerbitTambah. 

11. Isi tombol Tambah 

 

 

12. Isi tombol Ubah 
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13. Buka Menu Options dengan menu Project->Options atau (Shift+Ctr+F11) 
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14. Ubah agar DM diatas fPenerbitTampil dengan cara drag n drop 

 

15. Jalankan dengan F9 dan coba semua fiturnya. 
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BAB 2 

MENU UTAMA 

2.1 Menu Utama 

Menu Utama merupakan Form Utama yang menampilkan keseluruhan program, baik 

form maupun report.  

1. Buat Form Baru simpan unit dengan nama uUtama.pas 

 

2. Tambahkan 2 Label dan atur propertiesnya sebagai berikut 

Komponen Properties  Value Keterangan 

Form1 Name FUtama Mengubah nama menjadi 

‘FUtama’ 

 Caption SISTEM 

INFORMASI 

PERPUSTAKAAN 

Tampil tulisan ‘SISTEM 

INFORMASI PERPUSTAKAAN’ 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 
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Label1 Caption Login Sebagai : Mengganti Tulisan 

Label2 Caption - Mengganti Tulisan 

 Font-Color ClRed Mengganti Warna Huruf 

 

3. Tambahkan MainMenu pada Form 
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4. Double click MainMenu1 

 

5. Tuliskan pada caption “Data Master” 

 

6. Lanjutkan mengikuti gambar berikut 

 

7. Lanjutkan mengikuti gambar berikut 

 

8. Use Unit atau Alt+F11 fPenerbitTampil 
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9. Kembali ke MainMenu lalu Double Click Data Penerbit isi code berikut 

 

10. Atur pada menu Project-Options (Shift+Ctrl+F11) 

 

11. Selamat !! Anda sudah sukses membuat sebuah program yang memiliki menu utama 

dan 1 Form Master  
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12. Untuk menambahkan Form Master lagi dapat dilakukan dengan mengulang 

sebagian dari langkah-langkah diatas 

13. Bingung ? Mari kita lanjutkan pada Bab Berikutnya 
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BAB 3 

MENAMBAHKAN FORM MASTER 

3.1 Menambahkan Table Pada Database 

1. Buka File Access dbPerpus.mdb 

2. Pilih Tab Create-Table Design 

 

3. Isi Field seperti pada gambar, kemudian pada field IDPetugas klik gambar kunci 

untuk menentukan IDPetugas sebagai Primary Key 
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4. Ctrl+S atau klik kanan pada Tab Table1, simpan table dengan nama tPetugas 

 

5. Tutup Microsoft Access, guna menghindari error 

3.2 Menambahkan ADOQuery Baru 

1. Buka File Project Perpus.dpr atau menyesuaikan dengan nama project anda 

2. View Form (Sfhit+F12) Pilih DM 

3. Tambahkan ADOQuery (Tab ADO) dan Data Source (Tab Data Access) 

4. Atur properties dan values-nya 

Komponen Properties  Value Keterangan 

ADOQuery1 Connection CON Menghubungkan dengan 

ADOConnection (CON) 

 Name aPetugas Mengganti nama 

 SQL Select * from 

tPetugas 

Pilih Table yang akan diakses 

 Active True Mengaktifkan table yang diakses 

DataSource1 Name dPetugas Mengganti nama 

 DataSet aPetugas Menghubungkan dengan 

ADOQuery 
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3.3 Menambahkan Form Tampil Baru 

1. Buat Form Baru lewat File->New->Form 

 

atau 
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2. Simpan dengan nama uPetugasTampil.pas 

3. Kembali ke Form1, File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk 

menghubungkan dengan Data Module  

4. Tambahkan, 1 DBGrid (Tab Data Controls), 6 Button (Tab Standard), 1 Label (Tab 

Standard), 1 Edit (Tab Standard) 

 

5. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FPetugasTampil Mengubah nama menjadi 

‘FPetugasTampil’ 

 Caption Data Petugas Tampil tulisan ‘Data Petugas’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 
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Button1 Name bTambah Mengganti nama button 

 Caption &Tambah Tulisan menjadi Tambah, 

shortcut alt+T 

Button2 Name bUbah Mengganti nama button 

 Caption &Ubah Tulisan menjadi Ubah, shortcut 

alt+U 

Button3 Name bHapus Mengganti nama button 

 Caption &Hapus Tulisan menjadi Hapus, shortcut 

alt+H 

Button4 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Button5 Name bTutup Mengganti nama button 

 Caption Tutu&p Tulisan menjadi Tambah, 

shortcut alt+P, T dan U sudah 

dipakai 

Button6 Name bCari Mengganti nama button 

 Caption &Cari Tulisan menjadi Cari,  shortcut  

alt+C 

Label1 Caption Cari Petugas Mengganti tulisan 

Edit1 Name eCari Mengganti Nama 

 Text ‘’ Kosongkan tulisan 

DBGrid1 DataSource DM.dPetugas Memilih Data Source 

 Option-dgEditing False Agar Grid tidak bisa diketik 

 

6. Jika Semua pengaturan sudah selesai maka form menjadi seperti berikut 
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7. Double klik tombol Batal untuk mengisi codingnya dengan isi sebagai berikut 

 

 

8. Double klik tombol Hapus untuk mengisi codingnya dengan isi sebagai berikut 

 

 

9. Klik Form 1 Kali, Cari pada Events – On Show 

  

10. Double klik isi dengan kode berikut 
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11. Double klik tombol Cari untuk mengisi codingnya dengan isi sebagai berikut 

 

12. Untuk TOMBOL YANG PALING SUSAH alias bTutup isi sendiri ya  

13. Untuk tombol Tambah dan Ubah akan diisi setelah selesai dibuat form Tambah 

Data 

3.4 Form Data Tambah 

1. Buat Form Baru, Save dengan nama unit uPetugasTambah.pas 

2. Tambahkan 3 Label, 3 Edit, dan 2 Button 

 

3. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FPetugasTambah Mengubah nama menjadi 

‘FPetugasTambah’ 
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 Caption Tambah Petugas Tampil tulisan ‘Tambah 

Petugas’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bSimpan Mengganti nama button 

 Caption &Simpan Tulisan menjadi Simpan, 

shortcut alt+S 

Button2 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Label1 Caption Nama Petugas Mengganti tulisan 

Label2 Caption Username Mengganti tulisan 

Label3 Caption Password Mengganti tulisan 

 

 

 

4. File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk menghubungkan dengan Data 

Module 

5. File -> Use Unit (Alt+F11) -> Pilih uPetugasTampil. 

6. Double klik tombol Simpan untuk mengisi codingnya dengan isi sebagai berikut 
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7. Lagi lagi TOMBOL YANG PALING SUSAH yaitu tombol Batal isi sendiri ya.. 

8. Untuk pindah antar form bisa mengunakan Shift+F12 atau tombol berikut 

 

 

9. Kembali ke fPetugasTampil untuk mengisi tombol Tambah dan Ubah 

10. File -> Use Unit (Alt+F11) -> Pilih uPetugasTambah. 



34 

 

Modul Delphi: Mirza Yogy Kurniawan 

 

11. Isi tombol Tambah 

 

12. Isi tombol Ubah 

 

3.5 Menambahkan  Form Di Menu Utama 

1. Pindah ke Form Utama 
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2. File-Use Unit atau alt+F11 uPetugasTampil 

 

3. Double klik pada MainMenu1 

 

 

4. Pilih tempat kosong dibawah Data Penerbit dan isi caption dengan Data Petugas 

 

5. Double klik Data Petugas lalu isi dengan perintah sebagai berikut 
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6. Untuk pembuatan Form Master Baru lainnya bisa mengulang Bab 3 dengan 

mengganti field di database, pertanyaannya adalah, bagaimana untuk table yang 

berelasi? Mari kita lanjutkan pada bab berikutnya 
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BAB 4 

FORM MASTER DENGAN TABLE TERHUBUNG 

4.1 Menambahkan Table Pada Database 

1. Buka File Access dbPerpus.mdb 

2. Pilih Tab Create-Table Design 

3. Isi Field seperti pada gambar dan jadikan IDBuku sebagai Primary Key 

 

 

4. Ctrl+S atau klik kanan pada Tab Table1, simpan table dengan nama tBuku 

5. Klik Tab Database Tools lalu klik Relationships 
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6. Tambahkan tBuku dan tPenerbit 

 

7. Drag IDPenerbit di tPenerbit ke IDPenerbit di tBuku (atau sebaliknya sama saja) 

8. Dapat dilihat Relation Type nya adalah One-To-Many, masih ingat pelajaran Basis 

Data? 

9. Centang semua pilihan agar table terintegrasi. Klik Create 
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10. Save dan Tutup Relationships 

11. Buka tab Create, pilih Query Design 

 

12. Tambahkan tBuku dan tPenerbit, Tarik IDBuku dari tBuku, JudulBuku dari tBuku, 

Penulis dari tBuku, IDPenerbit dari tBuku, dan Penerbit dari tPenerbit 
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13. Pilih View -> SQLView, HAPUS TITIK KOMA (;), lalu Copy Query yang 

dihasilkan 

 

 

 

4.2 Menambahkan ADOQuery Baru 

5. Buka File Project Perpus.dpr atau menyesuaikan dengan nama project anda 

6. View Form (Sfhit+F12) Pilih DM 

7. Tambahkan ADOQuery (Tab ADO) dan Data Source (Tab Data Access) 

8. Atur properties dan values-nya 

Komponen Properties  Value Keterangan 

ADOQuery1 Connection CON Menghubungkan dengan 

ADOConnection (CON) 

 Name aBuku Mengganti nama 

 SQL PASTE DARI 

SQL VIEW 

Pilih Table yang akan diakses 

 Active True Mengaktifkan table yang diakses 

DataSource1 Name dBuku Mengganti nama 

 DataSet aBuku Menghubungkan dengan 

ADOQuery 
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4.3 Menambahkan Form Tampil Buku 

1. Buat Form Baru lewat File->New->Form 

2. Simpan dengan nama uBukuTampil.pas 

3. Kembali ke Form1, File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk 

menghubungkan dengan Data Module  

4. Tambahkan, 1 DBGrid (Tab Data Controls), 6 Button (Tab Standard), 1 Label (Tab 

Standard), 1 Edit (Tab Standard) 
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5. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FBukuTampil Mengubah nama menjadi 

‘FBukuTampil’ 

 Caption Data Buku Tampil tulisan ‘Data Buku’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bTambah Mengganti nama button 

 Caption &Tambah Tulisan menjadi Tambah, 

shortcut alt+T 

Button2 Name bUbah Mengganti nama button 

 Caption &Ubah Tulisan menjadi Ubah, shortcut 

alt+U 

Button3 Name bHapus Mengganti nama button 

 Caption &Hapus Tulisan menjadi Hapus, shortcut 

alt+H 

Button4 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Button5 Name bTutup Mengganti nama button 

 Caption Tutu&p Tulisan menjadi Tambah, 

shortcut alt+P, T dan U sudah 

dipakai 

Button6 Name bCari Mengganti nama button 

 Caption &Cari Tulisan menjadi Cari,  shortcut  

alt+C 

Label1 Caption Cari Petugas Mengganti tulisan 

Edit1 Name eCari Mengganti Nama 

 Text ‘’ Kosongkan tulisan 

DBGrid1 DataSource DM.dPetugas Memilih Data Source 

 Option-dgEditing False Agar Grid tidak bisa diketik 
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6. Jika Semua pengaturan sudah selesai maka form menjadi seperti berikut 

 

7. Double klik tombol bBatal untuk mengisi codingnya dengan isi sebagai berikut 

 

8. Double klik tombol bCari untuk mengisi codingnya dengan isi sebagai berikut 

 

SQL di tombol batal dan cari bisa dicopy dari SQL pada ADOQuery aBuku di 

DataModul 
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9. Untuk tombol hapus pada table yang memiliki foreign key dan field dari table lain 

tidak bisa menggunakan cara seperti dibawah ini 

 

10. Tambahkan ADOQuery di DataModul 

   

11. Atur propertiesnya 

Komponen Properties  Value Keterangan 

ADOQuery1 Name Q1 Mengganti nama 

 Connection CON Memilih ADO Connection 

 

12. Isi tombol bHapus 
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13. Klik Form 1 Kali, Cari pada Events – On Show 

  

14. Double klik isi dengan kode berikut 

 

 

 

 

 

 

 

 

 

 

 

15. Untuk TOMBOL YANG PALING SUSAH alias bTutup isi sendiri ya  

16. Untuk tombol Tambah dan Ubah akan diisi setelah selesai dibuat form Tambah 

Data 

4.4 Form Tambah Buku 

1. Buat Form Baru, Save dengan nama unit uBukuTambah.pas 

2. File -> Use Unit (Alt+F11) -> Pilih uDM. 

3. Tambahkan 3 Label, 2 Edit, 1 DBLookupCombobox, dan 2 Button 

DBLookupCombobox ada di tab Data Control 
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4. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FBukuTambah Mengubah nama menjadi 

‘FPetugasTambah’ 

 Caption Tambah Buku Tampil tulisan ‘Tambah 

Petugas’ 

 Align alCustom (optional) Jika ingin agar 

Form tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar 

Form tidak bisa 

diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar 

Form selalu muncul 

ditengah 

Button1 Name bSimpan Mengganti nama button 

 Caption &Simpan Tulisan menjadi Simpan, 

shortcut alt+S 

Button2 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, 

shortcut  

alt+B 
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Label1 Caption Judul Buku Mengganti tulisan 

Label2 Caption Penulis Mengganti tulisan 

Label3 Caption Penerbit Mengganti tulisan 

DBLookupCombobox1 ListSource DM.dPenerbit Menentukan sumber pilihan 

 ListField Penerbit Field yang ditampilkan 

sebagai pilihan 

 KeyField IDPenerbit Field yang akan disimpan 

 

5. File -> Use Unit (Alt+F11) -> Pilih uBukuTampil. 

6. Double klik tombol bSimpan untuk mengisi codingnya dengan isi sebagai berikut 

 

7. Isi bBatal dengan close; 

8. Pindah ke fBukuTampil. Untuk pindah antar form bisa mengunakan Shift+F12  

9. Use Unit (Alt+F11) uBukuTambah 

10. Isi tombol bTambah 
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11. Isi tombol bUbah 

 

4.5 Menambahkan  Form Di Menu Utama 

1. Pindah ke Form Utama 

2. File-Use Unit atau alt+F11 uPetugasTampil 

3. Double klik pada MainMenu1 

4. Pilih tempat kosong dibawah Data Penerbit dan isi caption dengan Data Buku 

5. Double klik Data Buku lalu isi dengan perintah  

fBukuTampil.showmodal; 

6. Harusnya sekarang tidak lagi ada masalah dalam pembuatan form master, baik yang 

memiliki foreign key ataupun tidak. Berikutnya kita bahas bagaimana dengan form 

master dengan berbagai macam inputan. 
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BAB 5 

FORM MASTER DENGAN BERAGAM INPUTAN 

 

5.1 Menambahkan Table Pada Database 

1. Buka File Access dbPerpus.mdb 

2. Pilih Tab Create-Table Design 

3. Isi Field seperti pada gambar dan jadikan IDAnggota sebagai Primary Key 

 

 

4. Ctrl+S atau klik kanan pada Tab Table1, simpan table dengan nama tAnggota 

5. Kali ini Primary Key akan kita buat dengan pengkodean otomatis 

6. Jenis Kelamin dengan inputan RadioGroup 

7. Tanggal Lahir dengan DateTimePicker 

8. Agama dengan Combobox 

9. Foto dengan OpenDialogPicture 

10. Tutup Microsoft Access, guna menghindari error 

5.2 Menambahkan ADOQuery Baru 

1. Buka File Project Perpus.dpr atau menyesuaikan dengan nama project anda 

2. View Form (Sfhit+F12) Pilih DM 

3. Tambahkan ADOQuery (Tab ADO) dan Data Source (Tab Data Access) 

4. Atur properties dan values-nya 
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Komponen Properties  Value Keterangan 

ADOQuery1 Connection CON Menghubungkan dengan 

ADOConnection (CON) 

 Name aAnggota Mengganti nama 

 SQL Select * from 

tAnggota 

Pilih Table yang akan diakses 

 Active True Mengaktifkan table yang diakses 

DataSource1 Name dAnggota Mengganti nama 

 DataSet aAnggota Menghubungkan dengan 

ADOQuery 

5.3 Menambahkan Form Tampil Baru 

1. Buat Form Baru lewat File->New->Form 

2. Simpan dengan nama uAnggotaTampil.pas 

3. Kembali ke Form1, File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk 

menghubungkan dengan Data Module  

4. Tambahkan, 1 DBGrid (Tab Data Controls), 6 Button (Tab Standard), 1 Label (Tab 

Standard), 1 Edit (Tab Standard) 

5. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FAnggotaTampil Mengubah nama menjadi 

‘FAnggotaTampil’ 

 Caption Data Anggota Tampil tulisan ‘Data Anggota’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bTambah Mengganti nama button 

 Caption &Tambah Tulisan menjadi Tambah, 

shortcut alt+T 

Button2 Name bUbah Mengganti nama button 

 Caption &Ubah Tulisan menjadi Ubah, shortcut 

alt+U 

Button3 Name bHapus Mengganti nama button 

 Caption &Hapus Tulisan menjadi Hapus, shortcut 
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alt+H 

Button4 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Button5 Name bTutup Mengganti nama button 

 Caption Tutu&p Tulisan menjadi Tambah, 

shortcut alt+P, T dan U sudah 

dipakai 

Button6 Name bCari Mengganti nama button 

 Caption &Cari Tulisan menjadi Cari,  shortcut  

alt+C 

Label1 Caption Cari Anggota Mengganti tulisan 

Edit1 Name eCari Mengganti Nama 

 Text ‘’ Kosongkan tulisan 

DBGrid1 DataSource DM.dAnggota Memilih Data Source 

 Option-dgEditing False Agar Grid tidak bisa diketik 

 

6. Double klik tombol Batal untuk mengisi codingnya dengan isi sebagai berikut 

 

 

7. Double klik tombol Hapus untuk mengisi codingnya dengan isi sebagai berikut 

 

 

8. Double klik tombol Cari untuk mengisi codingnya dengan isi sebagai berikut 
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17. Klik Form 1 Kali, Cari pada Events – On Show 

  

18. Double klik isi dengan kode berikut 

 

 

 

 

 

 

 

 

 

 

9. Untuk TOMBOL YANG PALING SUSAH alias bTutup isi sendiri ya  

10. Untuk tombol Tambah dan Ubah akan diisi setelah selesai dibuat form Tambah 

Data 
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5.4 Form Data Tambah 

1. Buat Form Baru, Save dengan nama unit uAnggotaTambah.pas 

2. Tambahkan 5 Label, 2 Edit,  3 Button, 1 Combobox (Tab Standard), 1 

RadioGroup (Tab Standard),  1 Image (Tab Additional) , 1 DateTimePicker (Tab 

Win32), 1 DBImage (Tab Data Controls), OpenPictureDialog (Tab Dialogs) 

 

3. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FAnggotaTambah Mengubah nama menjadi 

‘FanggotaTambah’ 
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 Caption Tambah Anggota Tampil tulisan ‘Tambah 

Anggota’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bSimpan Mengganti nama button 

 Caption &Simpan Tulisan menjadi Simpan, 

shortcut alt+S 

Button2 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Button3 Caption Pilih Gambar Mengganti Tulisan 

Image1 Stretch True Agar Gambar Menjadi Stretc 

Label1 Caption ID Anggota Mengganti tulisan 

Label2 Caption Nama Anggota Mengganti tulisan 

Label3 Caption Tanggal Lahir Mengganti tulisan 

Label4 Caption Agama Mengganti tulisan 

Label5 Caption Foto Mengganti tulisan 

RadioGroup1 Caption Jenis Kelamin Mengganti tulisan 

 Items (Double Klik 

Kolom isi 

dengan) Laki-laki 

Perempuan 

Mengisi Item 

 Columns 2 Mengganti Jumlah Kolom 

DateTimePicker1 Format dd/MM/yyyy (isi 

dengan M besar) 

Format Tanggal Indonesia 

ComboBox1 Items (Double Klik 

Kolom isi 

dengan) Buddha 

Hindu 

Islam 

Kristen Katolik 

Kristen Protestan 

Mengisi Item 

DBImage1 Visible False Sembunyikan 

 DataSource DAnggota  

 DataField FotoAnggota  
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4. File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk menghubungkan dengan Data 

Module 

5. File -> Use Unit (Alt+F11) -> Pilih uAnggotaTampil. 

6. Ketikkan jpeg dan clipbrd pada uses, cari lokasinya pada unit uAnggotaTambah 
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7. Double klik tombol Simpan untuk mengisi codingnya dengan isi sebagai berikut 

 

8. Double klik tombol Pilih Gambar 

 

9. Lagi lagi TOMBOL YANG PALING SUSAH yaitu tombol Batal isi sendiri ya.. 

10. Untuk pindah antar form bisa mengunakan Shift+F12  

11. Kembali ke fAnggotaTampil untuk mengisi tombol Tambah dan Ubah 

12. File -> Use Unit (Alt+F11) -> Pilih uAnggotaTambah. 
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13. Isi tombol Tambah 

 

14. Isi tombol Ubah 
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5.5 Menambahkan  Form Di Menu Utama 

1. Pindah ke Form Utama 

2. File-Use Unit atau alt+F11 uAnggotaTampil 

3. Double klik pada MainMenu1 

4. Pilih tempat kosong dibawah Data Buku dan isi caption dengan Data Anggota 

5. Double klik Data Anggota lalu isi dengan perintah  

fAnggotaTampil.showmodal; 

7. Setelah melaksanakan praktikum dengan modul-modul diatas harusnya sudah tidak 

ada lagi masalah penginputan data kedalam database, namun yang masih belum ada 

adalah validasi penginputan yang akan dibahas di bab akhir. 

8. Berikutnya kita bahas dulu bagaimana pembuatan form transaksi peminjaman 

 

 



59 

 

Modul Delphi: Mirza Yogy Kurniawan 

 

BAB 6 

FORM TRANSAKSI PEMINJAMAN 

 

6.1 Menambahkan Table Pada Database 

1. Buat table tPeminjaman 

 

2. Table Detail Peminjaman, table ini diperlukan karena dalam 1 Peminjaman harus 

bisa meminjam beberapa buku 

 

3. Table Sementara digunakan untuk menyimpan data buku yang dipinjam sebelum 

disimpan didalam table detail. 
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4. Susun Relationshipnya mengikuti gambar berikut 

 

5. Cara membuat Relasi dan Query dapat dilihat pada Bab 4 

6. Buat Query untuk peminjaman 
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7. Copy Querynya, jangan lupa HAPUS TITIK KOMA(;) 

 

8. Field TanggalPengembalian, Keterlambatan, dan DendaDibayar sengaja ditinggal 

karena field tersebut akan diisi pada proses pengembalian buku. 

6.2 Menambahkan ADOQuery Baru 

1. Buka File Project Perpus.dpr atau menyesuaikan dengan nama project anda 

2. View Form (Sfhit+F12) Pilih DM 

3. Tambahkan 3 ADOQuery (Tab ADO) dan 3 Data Source (Tab Data Access) 

4. Atur properties dan values-nya 

Komponen Properties  Value Keterangan 

ADOQuery1 Connection CON Menghubungkan dengan 

ADOConnection (CON) 

 Name aPeminjaman Mengganti nama 

 SQL PASTE DARI SQL 

VIEW 

Pilih Table yang akan 

diakses 

 Active True Mengaktifkan table yang 

diakses 

DataSource1 Name dPeminjaman Mengganti nama 

 DataSet aPeminjaman Menghubungkan dengan 

ADOQuery 

ADOQuery2 Connection CON Menghubungkan dengan 

ADOConnection (CON) 

 Name aDetailPeminjaman Mengganti nama 

 SQL SELECT * FROM 

TDETAILPEMINJAMAN 

Pilih Table yang akan 

diakses 

 Active True Mengaktifkan table yang 

diakses 

DataSource2 Name dDetailPeminjaman Mengganti nama 

 DataSet aDetailPeminjaman Menghubungkan dengan 

ADOQuery 

ADOQuery3 Connection CON Menghubungkan dengan 

ADOConnection (CON) 
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 Name aSementara Mengganti nama 

 SQL SELECT * FROM 

TSEMENTARA 

Pilih Table yang akan 

diakses 

 Active True Mengaktifkan table yang 

diakses 

DataSource3 Name dSementara Mengganti nama 

 DataSet aSementara Menghubungkan ADOQuery 

 

                   

6.3 Menambahkan Form Tampil Baru 

14. Buat Form Baru lewat File->New->Form 
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atau 

 

15. Simpan dengan nama uPeminjamanTampil.pas 

16. Kembali ke Form1, File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk 

menghubungkan dengan Data Module  

17. Tambahkan, 1 DBGrid (Tab Data Controls), 6 Button (Tab Standard), 1 Label (Tab 

Standard), 1 Edit (Tab Standard) 

 

18. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FPeminjamanTampil Mengubah nama menjadi 

‘FPeminjamanTampil’ 

 Caption Data Peminjaman Tampil tulisan ‘Data 

Peminjaman’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 
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 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bTambah Mengganti nama button 

 Caption &Tambah Tulisan menjadi Tambah, 

shortcut alt+T 

Button2 Name bUbah Mengganti nama button 

 Caption &Ubah Tulisan menjadi Ubah, shortcut 

alt+U 

Button3 Name bHapus Mengganti nama button 

 Caption &Hapus Tulisan menjadi Hapus, 

shortcut alt+H 

Button4 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Button5 Name bTutup Mengganti nama button 

 Caption Tutu&p Tulisan menjadi Tambah, 

shortcut alt+P, T dan U sudah 

dipakai 

Button6 Name bCari Mengganti nama button 

 Caption &Cari Tulisan menjadi Cari,  shortcut  

alt+C 

Label1 Caption Cari Petugas Mengganti tulisan 

Edit1 Name eCari Mengganti Nama 

 Text ‘’ Kosongkan tulisan 

DBGrid1 DataSource DM.dPeminjaman Memilih Data Source 

 Option-

dgEditing 

False Agar Grid tidak bisa diketik 

 

19. Jika Semua pengaturan sudah selesai maka form menjadi seperti berikut 
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20. Double klik tombol Batal untuk mengisi codingnya dengan isi sebagai berikut, 

Query bisa dicopy dari ADOQuery aPeminjaman atau dari SQL View Query MS 

Access 
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21. Double klik tombol Hapus untuk mengisi codingnya dengan isi sebagai berikut 

 

 

22. Klik Form 1 Kali, Cari pada Events – On Show 

  

23. Double klik isi dengan kode berikut 

 

 

 

 

 

 

 

 

 

24. Double klik tombol Cari untuk mengisi codingnya dengan isi sebagai berikut 
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25. Untuk TOMBOL YANG PALING SUSAH alias bTutup isi sendiri ya  

26. Untuk tombol Tambah dan Ubah akan diisi setelah selesai dibuat form Tambah 

Data 

6.4 Form Data Tambah 

13. Buat Form Baru, Save dengan nama unit uPetugasTambah.pas 

14. Tambahkan 4 Label, 4 Edit, dan 5 Button, 1 DBGrid 
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15. kemudian atur propertiesnya 

Komponen Properties  Value Keterangan 

Form1 Name FPeminjamanTambah Mengubah nama menjadi 

‘FPeminjamanTambah’ 

 Caption Tambah Peminjaman Tampil tulisan ‘Tambah 

Peminjaman’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bSimpan Mengganti nama button 

 Caption &Simpan Tulisan menjadi Simpan, shortcut 

alt+S 

Button2 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut  

alt+B 

Button3 Name bCariAnggota Mengganti nama button 

 Caption … Mengganti tulisan 

Button4 Name bCariBuku Mengganti nama button 

 Caption Tambah Buku Mengganti tulisan 

Button5 Name bHapusBuku Mengganti nama button 

 Caption Hapus Buku Mengganti tulisan 

Label1 Caption ID Anggota Mengganti tulisan 

Label2 Caption Nama Anggota Mengganti tulisan 

Label3 Caption Tanggal Pinjam Mengganti tulisan 

Label4 Caption Tanggal Harus 

Kembali 

Mengganti tulisan 

Edit1 ReadOnly True Agar Edit tidak bisa diketik 

Edit2 ReadOnly True Agar Edit tidak bisa diketik 

Edit3 ReadOnly True Agar Edit tidak bisa diketik 

Edit4 ReadOnly True Agar Edit tidak bisa diketik 

DBGrid1 DataSource DM.dSementara Memilih Data Source 

 Option-dgEditing False Agar Grid tidak bisa diketik 
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16. File -> Use Unit (Alt+F11) -> Pilih UDM, ini untuk menghubungkan dengan Data 

Module 

17. File -> Use Unit (Alt+F11) -> Pilih uPeminjamanTampil. 

18. Sebelum mengisi tombol bSimpan dan bBatal kita buat dulu form untuk pencarian 

anggota, pada dasarnya mirip dengan form tampil data anggota, bisa dilihat pada Bab 

5 
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19. Simpan dengan nama uCariAnggota.pas dan nama form fCariAnggota 

20. Use Unit atau Alt+F11 ke unit uPeminjamanTambah dan uDM 

21. Isi tombol bCari dengan 

 

22. Pilih DBGrid -> Events ->OnDblClick 

 

23. Kembali ke fPeminjamanTambah 

24. File -> Use Unit (Alt+F11) -> Pilih uCariAnggota. 

25. Isi bCariAnggota 

 

26. Form untuk pencarian buku, pada dasarnya mirip dengan form tampil data buku, bisa 

dilihat pada Bab 4 
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27. Simpan dengan nama uCariBuku.pas dan nama form fCariBuku 

28. Use Unit atau Alt+F11 ke unit uPeminjamanTambah dan uDM 

29. Isi tombol bCari dengan 

 

 

 

 

 



72 

 

Modul Delphi: Mirza Yogy Kurniawan 

 

 

30. Pilih DBGrid -> Events ->OnDblClick 

 

31. Kembali ke fPeminjamanTambah 

32. File -> Use Unit (Alt+F11) -> Pilih uCariBuku. 

33. Isi bCariBuku 

 

34. Isi bHapusBuku 
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35. Isi bSimpan 

 

36. Kembali ke fPeminjamanTampil untuk mengisi tombol Tambah dan Ubah 

37. File -> Use Unit (Alt+F11) -> Pilih uPeminjamanTambah. 

38. Isi tombol Tambah 
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39. Isi tombol Ubah 
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6.5 Menambahkan  Form Di Menu Utama 

1. Pindah ke Form Utama 

2. File-Use Unit atau alt+F11 uPeminjamanTampil 

3. Double klik pada MainMenu1 

4. Pilih tempat kosong dibawah Data Transaksi dan isi caption dengan Peminjaman 

5. Double klik Peminjaman lalu isi dengan perintah sebagai berikut 

fPeminjamanTampil.showmodal; 

6. Fiuh…. Form Transaksi memang melelahkan, karena banyak table yang terlibat dan 

control supaya tidak terjadi kesalahan, walaupun belum termasuk validasi. 

Berikutnya Transaksi Pengembalian. 
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BAB 7 

FORM TRANSAKSI PENGEMBALIAN 

 

7.1 Mengatur Form 

1. Buat form baru dan atur tampilan dan komponen 

 

2. Atur properties formnya 

Komponen Properties  Value Keterangan 

Form1 Name FPengembalian Mengubah nama menjadi 

‘FPengembalian’ 

 Caption Data Pengembalian Tampil tulisan ‘Data 

Pengembalian’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 
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tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bCariAnggota Mengganti nama button 

 Caption … Mengganti tulisan 

Button2 Name bSimpan Mengganti nama button 

 Caption &Simpan Tulisan menjadi Simpan, shortcut 

alt+S 

Button3 Name bBatal Mengganti nama button 

 Caption &Batal Tulisan menjadi Batal, shortcut 

alt+B 

Button4 Name bTutup Mengganti nama button 

 Caption &Tutup Tulisan menjadi Tutup, shortcut  

alt+T 

Label1 Caption ID Anggota Mengganti tulisan 

Label2 Caption Nama Anggota Mengganti tulisan 

Label3 Caption ID Peminjaman Mengganti tulisan 

Label4 Caption Tanggal Pinjam Mengganti tulisan 

Label5 Caption Tanggal Harus 

Kembali 

Mengganti tulisan 

Label6 Caption Tanggal Pengembalian Mengganti tulisan 

Label7 Caption Keterlambatan Mengganti tulisan 

Label8 Caption Denda Dibayar Mengganti tulisan 

Edit1 Readonly True Supaya Tidak Diisi 

Edit2 Readonly True Supaya Tidak Diisi 

Edit3 Readonly True Supaya Tidak Diisi 

Edit4 Readonly True Supaya Tidak Diisi 

Edit5 Readonly True Supaya Tidak Diisi 

Edit6 Readonly True Supaya Tidak Diisi 

Edit7 Readonly True Supaya Tidak Diisi 

DBGrid1 DataSource DM.dSementara Memilih Data Source 

 Option-

dgEditing 

False Agar Grid tidak bisa diketik 

 

7.2 Isi Event 

1. Use unit uCariAnggota, uDM 

2. Isi bCariAnggota 
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3. Isi bBatal 

 

4. Isi bCariAnggota 

 

5. Isi FormShow 

 

6. Ke Form Cari Anggota untuk mengganti DBGrid On DblClick 
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7. Tambahkan Use DateUtils agar perintah DaysBetween dikenali 

 

8. Kembali ke Form Pengembalian untuk mengisi bSimpan 
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9. Form pengembalian selesai, pasti pusing ya banyak yang diketik. Maka ketahuilah ini 

masih Form yang belum selesai, masih banyak fitur yang ditinggalkan, namun pada 

dasarnya sudah fungsional. 

10. Berikutnya adalah Pembuatan report/laporan 
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BAB 8 

REPORT DENGAN QUICKREPORT 

 

8.1 Instalasi QuickReport 

1. Buka Menu Component->Install Packages 

 

2. Pilih Add.. 

 

3. Cari di folder instalan Delphi, Program Files/Borland/Delphi/Bin 
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4. Cari file dclqrt70.bpl 

 

8.2 Pembuatan Report 

1. Buka Menu File-New-Other.. 
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2. Pilih Report 

 

3. Hasilnya 
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4. Save dengan nama uRPenerbit 

 

5. Use Unit uDM.pas 

6. Atur propertiesnya 

Komponen Properties  Value Keterangan 

QuickReport Name QRPenerbit Mengubah nama 

 DataSet Dm.aPenerbit Tampil tulisan ‘Data 

Peminjaman’ 

 Bands Klik pada tanda tambah (+) 
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7. Hasilnya 

 

8. Dari Tab QReport letakkan 1 (satu) QRLabel di Title, 2 (dua) QRShape, 2 (dua) 

QRLabel di Column Header, 2 (dua) QRShape, 1 (satu) QRExpr, dan 1 (satu) 

QRDBText. 

9. Hasilnya 
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10. Atur sedemikian rupa sehingga menjadi seperti berikut 

Komponen Properties  Value Keterangan 

QRLabel1 Caption Laporan Data Penerbit Mengubah tulisan 

 Font 

 

 

QRLabel2 Caption No  

QRLabel3 Caption Nama Penerbit  

QRShape1 Height 40  

 Width 40  

 Left 0  

 Top 0  

QRShape2 Height 40  

 Width 234  

 Left 39  

 Top 0  

QRShape3 Height 40  

 Width 40  

 Left 0  

 Top -2  

QRShape4 Height 40  

 Width 234  

 Left 39  

 Top -2  

QRExpr1 Expression count  

QRDBText1 DataSet DM.aPenerbit  

 DataField Penerbit  
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11. Hasilnya 

 

12. Kembali ke Form Utama, Use Unit UDM, dan URPenerbit 

13. Tambahkan pada menu Laporan-Data Penerbit 

 

14. Isikan seperti berikut 

 

15. Untuk data yang lain bisa diikuti langkah-langkah tadi dengan diganti DataSet nya 
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BAB 9 

LOGIN 

 

9.1 Form Login 

1. Buat Form baru simpan dengan nama unit uLogin 

 

2. Tambahkan 2 Label, 1 Edit, 1 Button dan 1 MaskEdit (Tab Additional) 
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3. Atur propertiesnya sebagai berikut 

Komponen Properties  Value Keterangan 

Form1 Name FLogin Mengubah nama  

 Caption LOGIN Tampil tulisan ‘LOGIN’ 

 Align alCustom (optional) Jika ingin agar Form 

tidak bisa digeser 

 BorderStyle bsDialog (optional) Jika ingin agar Form 

tidak bisa diperbesar/diperkecil 

 Position poDesktopCenter (optional) Jika ingin agar Form 

selalu muncul ditengah 

Button1 Name bLogin Mengganti nama button 

 Caption LOGIN Mengganti tulisan 

Label1 Caption Username Tulisan  

Label2 Caption Password Tulisan 

Edit1 Name eUser Mengganti nama 

MaskEdit1 Name ePass Mengganti nama 

 PasswordChar * Agar tulisan menjadi * 

 

4. Use Unit UUtama dan UDM 

5. Kembali pada menu utama Use Unit ULogin 

6. Isi FormShow Pada Form Utama 
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7. Isi Logout Pada Menu dengan 

 

8. Pindah ke Form Login isi tombol Login dengan 

 

9. Untuk mengujinya jangan lupa isi dulu data petugas 


